AIX Tape Device Management

When using tape devices it is often necessary to change parameters to tune for performance. This QRG describes the process for changing configuration parameters for AIX tape devices to tune for optimal performance. The parameters used are the recommended settings which are often specified by the application using the device or the device manufacturer.

Listing Devices

The following command lists all the devices configured on a system. It should be used to determine the exact device to manage.

The example provided here uses these commands to change the block size for a tape device.

Command:

lsdev

Output example:

# lsdev
L2cache0   Available               L2 Cache
aio0       Defined                 Asynchronous I/O (Legacy)
cd0        Available 05-08-00      IDE DVD-ROM Drive
en0        Available 03-08         Standard Ethernet Network Interface
en1        Defined   03-09         Standard Ethernet Network Interface
ent0       Available 03-08         2-Port 10/100/1000 Base-TX PCI-X Adapter (14108902)
ent1       Available 03-09         2-Port 10/100/1000 Base-TX PCI-X Adapter (14108902)
et0        Defined   03-08         IEEE 802.3 Ethernet Network Interface
et1        Defined   03-09         IEEE 802.3 Ethernet Network Interface
fcnet0     Defined   01-08-01      Fibre Channel Network Protocol Device
fcs0       Available 01-08         FC Adapter
fcs1       Defined   01-08         FC Adapter
fscsi1     Available 01-08-02      FC SCSI I/O Controller Protocol Device
fwdump     Defined                 Logical volume
gxme0      Defined                 Graphics Data Transfer Assist Subsystem
hd1        Defined                 Logical volume
hd2        Defined                 Logical volume
hd3        Defined                 Logical volume
hd4        Defined                 Logical volume
hd5        Defined                 Logical volume
hd6        Defined                 Logical volume
hd8        Defined                 Logical volume
hd10opt    Defined                 Logical volume
hd9var     Defined                 Logical volume
hdisk0     Available 06-08-01-5,0  16 Bit LVD SCSI Disk Drive
hdisk1     Available 06-08-01-8,0  16 Bit LVD SCSI Disk Drive
ide0       Available 05-08         ATA/IDE Controller Device
inet0      Available               Internet Network Extension
iscsi0     Available               iSCSI Protocol Device
lo0        Available               Loopback Network Interface
loglv00    Defined                 Logical volume
lv00       Defined                 Logical volume
lvdd       Available               LVM Device Driver
mem0       Available               Memory
pci0       Available               PCI Bus
pci1       Available               PCI Bus
pci2       Available               PCI Bus
pci3       Available 00-10         PCI Bus
pci4       Available 00-12         PCI Bus
pci5       Available 00-13         PCI Bus
pci6       Available 00-14         PCI Bus
posix_aio0 Defined                 Posix Asynchronous I/O
proc0      Available 00-00         Processor
proc2      Available 00-02         Processor
pty0       Available               Asynchronous Pseudo-Terminal
rcm0       Defined                 Rendering Context Manager Subsystem
rmt0       Available 01-08-02      Other FC SCSI Tape Drive
rmt1       Available 01-08-02      Other FC SCSI Tape Drive
rootvg     Defined                 Volume group
scsi0      Available 06-08-00      PCI-X Dual Channel Ultra320 SCSI Adapter bus
scsi1      Available 06-08-01      PCI-X Dual Channel Ultra320 SCSI Adapter bus
ses0       Available 06-08-01-15,0 SCSI Enclosure Services Device
sisscsia0  Available 06-08         PCI-X Dual Channel Ultra320 SCSI Adapter
sys0       Available               System Object
sysplanar0 Available               System Planar
usb0       Available               USB System Software
usbhc0     Available 04-08         USB Host Controller (33103500)
usbhc1     Available 04-09         USB Host Controller (33103500)
vio0       Available               Virtual I/O Bus
vsa0       Defined                 LPAR Virtual Serial Adapter
vsa1       Available               LPAR Virtual Serial Adapter
vty0       Defined                 Asynchronous Terminal
vty1       Available               Asynchronous Terminal

List Device Attributes

After obtaining the device insurance more details for the device can be shown using the lsattr command.

Command syntax:

lsattr -l <DEVICE> -E

Output example:

bu07# lsattr -l rmt2 -E
block_size     512                BLOCK size (0=variable length)            True
delay          45                 Set delay after a FAILED command          True
density_set_1  0                  DENSITY setting #1                        True
density_set_2  0                  DENSITY setting #2                        True
extfm          yes                Use EXTENDED file marks                   True
location                          Location Label                            True
lun_id         0x3000000000000    Logical Unit Number ID                    False
mode           yes                Use DEVICE BUFFERS during writes          True
node_name      0x500a09800000a7af FC Node Name                              False
res_support    no                 RESERVE/RELEASE support                   True
ret_error      no                 RETURN error on tape change or reset      True
rwtimeout      144                Set timeout for the READ or WRITE command True
scsi_id        0x10800            SCSI ID                                   False
var_block_size 0                  BLOCK SIZE for variable length support    True
ww_name        0x510a09800000a7af FC World Wide Name                        False
bu07#
bu07# lsdev
L2cache0   Available               L2 Cache
aio0       Defined                 Asynchronous I/O (Legacy)
cd0        Available 05-08-00      IDE DVD-ROM Drive
en0        Available 03-08         Standard Ethernet Network Interface
en1        Defined   03-09         Standard Ethernet Network Interface
ent0       Available 03-08         2-Port 10/100/1000 Base-TX PCI-X Adapter (14108902)
ent1       Available 03-09         2-Port 10/100/1000 Base-TX PCI-X Adapter (14108902)
et0        Defined   03-08         IEEE 802.3 Ethernet Network Interface
et1        Defined   03-09         IEEE 802.3 Ethernet Network Interface
fcnet0     Defined   01-08-01      Fibre Channel Network Protocol Device
fcs0       Available 01-08         FC Adapter
fcs1       Defined   01-08         FC Adapter
fscsi1     Available 01-08-02      FC SCSI I/O Controller Protocol Device
fwdump     Defined                 Logical volume
gxme0      Defined                 Graphics Data Transfer Assist Subsystem
hd1        Defined                 Logical volume
hd2        Defined                 Logical volume
hd3        Defined                 Logical volume
hd4        Defined                 Logical volume
hd5        Defined                 Logical volume
hd6        Defined                 Logical volume
hd8        Defined                 Logical volume
hd10opt    Defined                 Logical volume
hd9var     Defined                 Logical volume
hdisk0     Available 06-08-01-5,0  16 Bit LVD SCSI Disk Drive
hdisk1     Available 06-08-01-8,0  16 Bit LVD SCSI Disk Drive
ide0       Available 05-08         ATA/IDE Controller Device
inet0      Available               Internet Network Extension
iscsi0     Available               iSCSI Protocol Device
lo0        Available               Loopback Network Interface
loglv00    Defined                 Logical volume
lv00       Defined                 Logical volume
lvdd       Available               LVM Device Driver
mem0       Available               Memory
ovpass0    Available 01-08-02      VERITAS Media Changer
pci0       Available               PCI Bus
pci1       Available               PCI Bus
pci2       Available               PCI Bus
pci3       Available 00-10         PCI Bus
pci4       Available 00-12         PCI Bus
pci5       Available 00-13         PCI Bus
pci6       Available 00-14         PCI Bus
posix_aio0 Defined                 Posix Asynchronous I/O
proc0      Available 00-00         Processor
proc2      Available 00-02         Processor
pty0       Available               Asynchronous Pseudo-Terminal
rcm0       Defined                 Rendering Context Manager Subsystem
rmt0       Available 01-08-02      Other FC SCSI Tape Drive
rmt1       Available 01-08-02      Other FC SCSI Tape Drive
rmt2       Available 01-08-02      Other FC SCSI Tape Drive
rmt3       Available 01-08-02      Other FC SCSI Tape Drive
rootvg     Defined                 Volume group
scsi0      Available 06-08-00      PCI-X Dual Channel Ultra320 SCSI Adapter bus
scsi1      Available 06-08-01      PCI-X Dual Channel Ultra320 SCSI Adapter bus
ses0       Available 06-08-01-15,0 SCSI Enclosure Services Device
sisscsia0  Available 06-08         PCI-X Dual Channel Ultra320 SCSI Adapter
sys0       Available               System Object
sysplanar0 Available               System Planar
usb0       Available               USB System Software
usbhc0     Available 04-08         USB Host Controller (33103500)
usbhc1     Available 04-09         USB Host Controller (33103500)
vio0       Available               Virtual I/O Bus
vsa0       Defined                 LPAR Virtual Serial Adapter
vsa1       Available               LPAR Virtual Serial Adapter
vty0       Defined                 Asynchronous Terminal
vty1       Available               Asynchronous Terminal
bu07#

List the rmt2 device and change the block size to variable.

Command syntax:

# lsattr -l rmt2 -E

Output example:

bu07# lsattr -l rmt2 -E
block_size     512                BLOCK size (0=variable length)            True
delay          45                 Set delay after a FAILED command          True
density_set_1  0                  DENSITY setting #1                        True
density_set_2  0                  DENSITY setting #2                        True
extfm          yes                Use EXTENDED file marks                   True
location                          Location Label                            True
lun_id         0x3000000000000    Logical Unit Number ID                    False
mode           yes                Use DEVICE BUFFERS during writes          True
node_name      0x500a09800000a7af FC Node Name                              False
res_support    no                 RESERVE/RELEASE support                   True
ret_error      no                 RETURN error on tape change or reset      True
rwtimeout      144                Set timeout for the READ or WRITE command True
scsi_id        0x10800            SCSI ID                                   False
var_block_size 0                  BLOCK SIZE for variable length support    True
ww_name        0x510a09800000a7af FC World Wide Name                        False
bu07#

Need to change the current setting from 512 to 0. Use the chdev command.

Command syntax:

# chdev -l rmt2 -a block_size=0

Output example:

bu07# chdev -l rmt2 -a block_size=0
rmt2 changed
bu07# lsattr -l rmt2 -E
block_size     0                  BLOCK size (0=variable length)            True
delay          45                 Set delay after a FAILED command          True
density_set_1  0                  DENSITY setting #1                        True
density_set_2  0                  DENSITY setting #2                        True
extfm          yes                Use EXTENDED file marks                   True
location                          Location Label                            True
lun_id         0x3000000000000    Logical Unit Number ID                    False
mode           yes                Use DEVICE BUFFERS during writes          True
node_name      0x500a09800000a7af FC Node Name                              False
res_support    no                 RESERVE/RELEASE support                   True
ret_error      no                 RETURN error on tape change or reset      True
rwtimeout      144                Set timeout for the READ or WRITE command True
scsi_id        0x10800            SCSI ID                                   False
var_block_size 0                  BLOCK SIZE for variable length support    True
ww_name        0x510a09800000a7af FC World Wide Name                        False
bu07#

Summary

# lsattr -l rmt3 -E

# chdev -l rmt3 -a block_size=0

# lsattr -l rmt3 -E

Advertisement